• Feedback by UserVoice
  • Tell us how we can improve Skype for Business

    Add option to disable "Automatically adjust microphone settings" in Skype for Business client.

    Need the option to disable the "Automatically adjust microphone settings" in Skype for Business client.
    This option is available in "Skype" but not "Skype for Business".
    This is needed if you use SfB in a noisy or call center environment.

    If you use SfB certified headsets with the best microphone noise cancellation it made useless, since the volume is adjusted in windows sound settings automatically by SfB.

    This is really bad and unworkable scenario in call center(RGS) environment when the microphone level auto adjust when you make SfB calls, the clients clearly hears all the adjacent agents speak.

    1,863 votes
    Vote
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      You have left! (?) (thinking…)
      Wielligh shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

      90 comments

      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)
        Submitting...
        • BattleshipCobra commented  ·   ·  Flag as inappropriate

          I did the registry key edit and it still messes up my mic, every single time it sets the volume to 20%. Nothing else does it so frustrating.

        • Anonymous commented  ·   ·  Flag as inappropriate

          My SfB automatically moves recording level to 100, which distorts the sound. I would like to disable the auto-adjust default to prevent this from happening.

        • Colin commented  ·   ·  Flag as inappropriate

          This is interesting, because the option already exists, it's just not on by default. The option becomes visible to disable auto mic gain adjustment to Skype for Business via a single registry key:

          1. In regedit, go to: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Lync
          2. Add a DWORD: ShowAutomaticGainControlOption
          3. Set it to 1
          4. Restart Skype for Business

          Now, in Skype for Business under Tools -> Options -> Audio Device, we can see the checkbox "Automatically adjust microphone volume on calls." By default, it's checked.

        • John commented  ·   ·  Flag as inappropriate

          My guess is with the move to teams there will be no further S4B development. However, this option seems to already be available. You just need to show it S4B by enabling it with some registry settings: https://support.microsoft.com/en-us/help/4054427/disable-automatic-gain-control-skype-for-business-windows. After setting this and restarting S4B the option to turn automatic gain is available.

        • Damien commented  ·   ·  Flag as inappropriate

          Here's an idea, how about letting someone set their upper threshold. Then you'd still have something to work with if they talk to loud and saturate the input.

        • Damien commented  ·   ·  Flag as inappropriate

          Work in an open plan development area with lots of people discussing things around me. Skype is detecting their voices and slow ramping up the gain until it hits 100% I'm constantly having to hover over the mute button. The mic is right beside my face. I just need to set it to 5% max... but this stupid (lack of option) won't let me. Obviously Microsoft speakers are set to 0% cuz there's so many comments saying the same thing and yet no one is listening.

        • Anna commented  ·   ·  Flag as inappropriate

          Agility and open plan means this is really needed in Business - can anyone from MS confirm whether this is on the roadmap or not?

        • Jack commented  ·   ·  Flag as inappropriate

          As QA, I cant believe this "feature" made it into a production build

        • Jack commented  ·   ·  Flag as inappropriate

          My entire team is trying to convince IT to let us use an alternative meeting software because this god dam feature fuqs all our mic volume

        • rob commented  ·   ·  Flag as inappropriate

          I persuade everyone I meet not to use Skype for business for this reason. People need control over the DB sensitivity for all sorts of reasons. There are quite afew other viop's out there now that function much better than Skype.

        • Fiver Hoo fiver commented  ·   ·  Flag as inappropriate

          worlds stupidest feature. Are the MS project teams that develop this even dogfooding it? Or are they all using something that actually works. Like slack.

        • [Deleted User] commented  ·   ·  Flag as inappropriate

          ***** psyched today about using Skype for business just to find out my microphone drops to 40 autoamtically when initiating a call and then to find out this has been an issue for years.......happy we found out early...

        • Andy commented  ·   ·  Flag as inappropriate

          It is unforgivable that this feature is not available. I get frustrated every time we have a team call b/c I can hear myself coming through my coworker's mic. arg!

        • Anonymous commented  ·   ·  Flag as inappropriate

          This needs to be fixed.
          It is the main reason that I maintain a Go To Meeting account.

        • otto commented  ·   ·  Flag as inappropriate

          unfortunately they have removed the switch that allows you to shut off automatic microphone level adjust on Mac consumer version of Skype, too, as of last update. 8.24.0.2. june 2018. for some reason, skype updates itself automatically (why is this even allowed?) so i did not actually install this new poor version myself. previously it had the switch for this under audio-video settings menu, and it did work, but it would reset itself to the bad auto-adjust way when you restarted skype, and you had to set it back to the good manual way yourself again. but at least it worked. now my mic volume is back to the "jump all over the place" mode all the time. it's like in all of microsoft there are no audio engineers or they are all in budget meetings all day. my theory is that we will have to find a way in Windows Registry or mac Kernel settings or something like that to blockade this errant app from messing with the audio video settings of the hardware. how do this this, i dont know... there must be a way... blockade... think: blockade...

        • Elizabeth Greene commented  ·   ·  Flag as inappropriate

          I found a way to turn this off.

          reg add "HKLM\Software\Microsoft\RTC\DeviceSettings" /v "AnalogAGC" /t REG_DWORD /d "0"
          reg add "HKLM\Software\Microsoft\RTC\DeviceSettings" /v "DigitalAGC" /t REG_DWORD /d "0"
          reg add "HKLM\Software\Wow6432Node\Microsoft\RTC\DeviceSettings" /v "AnalogAGC" /t REG_DWORD /d "0"
          reg add "HKLM\Software\Wow6432Node\Microsoft\RTC\DeviceSettings" /v "DigitalAGC" /t REG_DWORD /d "0"

        ← Previous 1 3 4 5

        Feedback and Knowledge Base