Tell us how we can improve Skype for Business

Disable pop-up notifications

Allow users to disable desktop pop-up notifications at all times rather than only when status is set to do not disturb.

702 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    44 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • DavidDavid commented  ·   ·  Flag as inappropriate

        PLEASE add the option to prevent instant messages from being shown on the screen, as mentioned numerous times below, completely unnecessary, potentially challenging / embarrassing and definitely not functionality required for business. As suggested below a simple flash of the Skype icon in the tool bar to indicate a new message would suffice. Please send out a patch ASAP or we will be forced to disable this application.

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        I hate the contact picture pop-ups when someone starts a conversation. Please add an option to disable. It is interrupting. Distracting. Anoying. Completely undesirable. MAKE IT STOP.

      • Shawn DennyShawn Denny commented  ·   ·  Flag as inappropriate

        Allow CsImConfiguration cmdlet to be available to Office 365 tenant admins so we can turn off offline messaging like on-premise users can.

      • YvonneYvonne commented  ·   ·  Flag as inappropriate

        If this is helpful at all, I always expand my monitor, instead of duplicating when I am presenting. This way, I can keep all of those pesky popups on my computer, and just the presentation itself on the second monitor/overhead. I know this is not practical for all meetings. It would be nice if this were fixed.

      • Chris_ChomyczChris_Chomycz commented  ·   ·  Flag as inappropriate

        This should be a setting somewhere. During a presentation the behavior is to display a toast notification that someone is trying to add a message. This is pretty counter-intuitive since you are trying to run a presentation. Chances are you might have someone else moderating and don't want to keep seeing the IM popup that content is being added. I have found a work around for meeting itself by initially typing a IM from the presenting machine, but it's pretty stupid we just can't disable this.

      • Anonymous commented  ·   ·  Flag as inappropriate

        This is terrible. I constantly have windows where the scroll bar is on the bottom right of the screen and every time someone signs on it goes to that instead of the scroll bar. I have started just turing SFB off.

      • MeMe commented  ·   ·  Flag as inappropriate

        Come on and fix this already. Now the only option is to be in DND-mode. But I want to be able to be available, but with out that anoying desktop popup. Just a small blink in the taskbar is enough!!!

      • Nikki PNikki P commented  ·   ·  Flag as inappropriate

        i find it dumb that normal skype can disable pop up notifications in the corner when someone IM's you but skype for business cannot......UM WHY? it freezes my ENTIRE computer and screen every time i get one and it then pops in front of whatever i have open. if someone IM's me i would like it to flash on task bar and display behind whatever i have open.

      • Sebastian K.Sebastian K. commented  ·   ·  Flag as inappropriate

        It is absolutely unacceptable that programmers of the software does not examine in depth the business use or functionality of the software. The Lync offered that option among other things. I found myself being in a very difficult position the other day due to the fact that I was sent a confidential message about someone in my company and the person that was mentioned in the message was standing next to me and saw the message!! The sender of the message didn’t thought that the person that was talking about would be in my office at that time and I was placed in a very difficult position as you may imagine. I am forced to use other IM in my phone now in order to be on the safe side! Absolutely ridiculous and absurd…..This in not a “Business” application….it is a **** that may get you in real trouble…Either fix it or stop using the term Skype for Business…because it seems that you do not have the slightest idea what happens in a business environment…. We are reaching 2017 and still the problem exits….How many months do you thing you “Skype Programmers” require to fix something that is so simple but at the same time so important? I personally minimize its use and suggest to my friends to avoid it…

      • AnonymousAnonymous commented  ·   ·  Flag as inappropriate

        I want to remove message previews. Im sick of having potentially sensitive HR information pop up on my screen as a message preview. The sender doesnt know who is at my desk talking to me, and having to start every conversation with "Hey" is annoying. PLEASE add the ability to disable message previews!!! This should be a no-brainer.. cant believe this function doesnt exist.

      • Silvio ReisSilvio Reis commented  ·   ·  Flag as inappropriate

        There is option to do that, right-click the contact (or select more than one) and um-check "tag and status...". After a few clicks the default becoming no notifications (can anyone check if is is true?), but everyone looks for a global configuration option - no notifications of this type for anyone and anytime!

      • souqisouqi commented  ·   ·  Flag as inappropriate

        highlight the contact name then click right mouse botton to un-check "tag and status change alerts" to stop the pop-up notifications

      • JefJef commented  ·   ·  Flag as inappropriate

        We just started using this and found that the disabling of the annoying alerts - when someone sits down, stands up, gets coffee, etc. - is on the right-click context menu on the contacts list. Select one or more contacts and right-click. Untick the "Tag for status change alerts" and enjoy the peace. Not obvious, hard to find (especially judging by the comments here), but it's there,
        Enjoy...

      • Bernard Abernathy, M.SciBernard Abernathy, M.Sci commented  ·   ·  Flag as inappropriate

        I too would like add to my thoughts and opinions to this. It is mind boggling that Skype for Business actually removed functionality, instead of giving Users the option as to how they would like to interact with their software. I shall hope this feature is resolved soon and someone gets their comeuppance.

      • Anthony OliveAnthony Olive commented  ·   ·  Flag as inappropriate

        Such a moronic feature, the fact that Skype doesn't have this as an option shows what garbage this software is. The most basic old IM service allows you to block popups, completely idiotic.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I want to throw it out the window even when I am in Skype it still pops up please let it stop

      Feedback and Knowledge Base